Otters UK - Global IT Incident affecting payments – Incident details

All systems operational

Global IT Incident affecting payments

Resolved
Operational
Started 4 months agoLasted 2 days
Updates
  • Resolved
    Resolved

    As of July 22, 04:36AM BST, it looks like all financial services have recovered and any potentially backlogged payments have resorbed and therefore been processed accordingly.

    We will therefore be marking this incident as resolved. We are continuing to monitor the impact of the Crowdstrike outage on any other services.

  • Update
    Update

    We are aware that the impact of the incident is now minimal, however, we are still being told some payments may still be affected by this incident. We are not currently reporting any issues with payments at this time.

    We remain closely monitoring the incident and hope a resolution is found as soon as possible.

  • Monitoring
    Monitoring

    Otters is aware of a global IT incident starting July 19th. Our payment services remain operational.

    We have been made aware by our payment processor, Stripe, that due to a service interruption with one of their partner banks linked to the Global IT incident some individuals may encounter issues processing new payments. We are also aware that lapsing payments may fail to process. Otters has not received reports from any prospective or existing clients of issues like these yet.

    We are aware that this interruption only affects a small cluster of payment methods that may not be available to all clients.

    We are closely monitoring the situation and will update this once we hear an update.